jump to navigation

Python developer working space on Mac OS X November 25, 2007

Posted by xenator in Code.
Tags: , , , , , , ,
4 comments

50% of developer’s success is IDE. We as open source citizens using open source products for developing and deploying, and most of us using Eclipse as primary Python IDE. May be you choose to switch it after this article.

How to setup your working environment 

There is only 5 easy steps to be happy with amazing Python development process. 

Install MacPorts 

As python developer you need python. Let system use system python, we need developer’s python for development. Go to MacPorts download area and grab latest version (something like MacPorts-1.5.0-10.4.dmg). Then install it.

Install python and Postgres

Now open Terminal and run:

$sudo port install python24 py-readline py-pil postgresql82 postgresql82-server subversion psycopg

And follow instructions, Postgres need your attentions! Personally for me I’m adding to this list:

$sudo port install iTerm joe mc

iTerm – better than Terminal.app, joe – good console editor (useful if you need quick edit some system files), and mc – console file manager saving some more time on regular files operations. Now, you have python and postgres.

Install Eclipse and extensions

Open Eclipse.org/downloads in your browser. I’m download Eclipse IDE for Java Developers because it contain some of extensions that I need. Run Eclipse and open `Help/Software Update/Find and Install` menu. Then add this repositories to list:

Check box near Europa Discovery Site and press Finish button. Then select extensions for Eclipse 3.3 from new repositories. And add this items from Europa list:

  • Graphical Editing Framework
  • Graphical Modeling Framework
  • Web Standard Tools
  • Object Constraint Language
  • UML 2 End User Features
  • UML 2 Tools
  • XML Schema Infoset Model (XSD) Extender SDK
  • Eclipse XML Editors and Tools 

Don’t forget press “Select Required” before press “Next>” and complete install wizard. Close and open again Eclipse (sometimes “Restart” not working properly) 

Configure Eclipse and extensions

 There is only two thing I need to say you.

  • First is error in SVN options (Eclipse menu/Preferences, Team/SVN), you need to select SVNKit as SVN Interface
  •  Second go to Pydev/Interpreter Python, press New… and find `/opt/local/Library/Frameworks/Python.framework/Versions/2.4/bin/python2.4` then press Apply

Install Zope

Last step: It depends on what Zope version you want to use.

  • If you use Zope 3.3, then get Zope-3.3.0.tgz , unpack and read INSTALL.txt
  • Zope 3.4 based on egg python distributions. Use this instructions to install it.

Congratulations! 

Now you are ready for Hivurt Revolution